Message thread on Webots Real Robots

Cannot find Bluetooth port connection in robot windowby Jiaxiao CAU (10) 2017-03-21 04:54:57
I am currently working on real robot experiment using two e-puck I purchased from you.
I used Webots for programming and tried to use "robot window" to control my real e-puck through Bluetooth.
One of my robot is emitter, while another one is receiver.
I find that the emitter can be controlled through "robot window" while the receiver can not.
I also noticed several sample provided by cyberbotics such as "slam" and "advance_path_planning" cannot be controlled via Bluetooth through "robot window". Therefore, I turn to you for help. It is possible to control my real e-puck through webots in this circumstance.
Attached pls find my file.

I would be very appreciate if you could reply me at your earliest convenience.

Attachment: help.zip.
Re: Cannot find Bluetooth port connection in robot windowby Olivier Michel (Webots PRO - 883) 2017-03-21 17:59:40
Dear Jiaxiao Cau,

I could isolate the problem. It seems to be a bug caused by the display device. If you remove any call the wb_display_* API in your controller, then it works in remote control. This is because a real e-puck has no display device.

We will fix this bug in the next version of Webots. Meanwhile I would recommend you as a work around to disable the wb_display_* function in your e-puck controller programs.

Please let me know if that works for you.

Best regards,

-Olivier
Re: Cannot find Bluetooth port connection in robot windowby Jiaxiao CAU (10) 2017-03-22 01:26:37
thanks so much
you are helpful!
Re: Cannot find Bluetooth port connection in robot windowby Jiaxiao CAU (10) 2017-03-22 05:13:02
Dear Olivier,
It works in the first trail. After the first trial, it doesn't work now.
Re: Cannot find Bluetooth port connection in robot windowby Olivier Michel (Webots PRO - 883) 2017-03-22 08:23:28
Dear Jiaxiao Cau,

That is very strange and deserves another try. Sometimes, the e-puck connection is not very reliable and you have to re-try it (you need to switch off the real e-puck and switch it on again). Otherwise, do you get any error message in the Webots console?

Best regards,

-Olivier
You need to log in to be able to reply, subscribe or unsubscribe to this thread